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Installation: STOP STOP STOP - READ BELOW

CD Rom Installation:
1) Remove the CD from its case by pushing the button in the center of the CD to release it.  Don’t try
prying the CD out of its case. Insert CD into drive.
2) Double click on My Computer
3) Double click on the icon that represents your CD Rom Drive.
4) Double click on Setup.

This will start the software installation program. Follow the instructions on the screen.  Please note, you are
asked to enter a Password Installation Key for the software you are installing.  This number is printed on
a sticker inside your software case. DO NOT LOSE THIS NUMBER. You will need it for all future
installations.
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What Else Should I Do Before Using This Software

Before using this software package you should check two additional settings on your computer.

1) Make sure the Windows Taskbar is set to Auto Hide.  Without being set to Auto hide, the Taskbar will
block the navigational buttons at the bottom of the screen that allow you to move from record to record.
When set to Auto hide, the Taskbar will be taken out of the way of these buttons, allowing you to easily
navigate through each record. To set the Windows Taskbar to Auto Hide follow the instructions below.

A) Right click on an empty section of your Taskbar
B) A pop up menu appears. Click Properties.
C) Check Auto Hide  (Auto Hide Taskbar)
D) Click OK
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2) Make sure your screen resolution is set to 800 by 600 or 1024 by 768 Pixels. To change the screen
resolution follow these directions.
A) Right Click anywhere on the Windows Desktop, and a pop up menu will appear.
B) Click on Properties, and a window will pop up.
C) Click on the Settings tab.
D) In the Screen Area section, slide the slider to the left or right until the screen area is 800 by 600  Pixels
or 1024 by 768 Pixels (recommended).
E) Click Apply.
The screen will then resize. When Windows asks you whether or not you would like to keep these settings,
click Yes, or Windows will restore your previous settings.

Using CompuCarpet For The First Time
The first thing you should do when running CompuCarpet for the first time is to run  the Setup Wizard.
The Setup Wizard will help you quickly and easily setup your system default values. The Setup Wizard will
prompt you at every step and save the information to your system.  To access the Setup Wizard click on File
on the main screen and then click on Run Setup Wizard.
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Running The Setup Wizard

From the File menu on the main screen click on Run Setup Wizard.

1) Enter your store name.
2) Enter your name
3) Enter the street address, city, state and zip where your store is located.
4) Enter the store phone and fax number, your e-mail address, and your website url.
5) Enter your markup rate. Simply enter your markup rate and the software will automatically calculate the retail
price of every carpet you carry in your store without you having to do a thing. The default value entered is 1.6.
Don’t enter symbols such as $ or %, the software will not allow these. Just enter the numbers.
6) Enter the price of what you charge for the carpet pad.  This pad price will be calculated into the total price
per square yard.
7) Enter what you charge per square yard for installation labor.
8) If you sell area carpets, enter the price per linear foot you charge for having a carpet bound.
9) Enter Your Price Ranges.  The software gives you the ability to rate your carpets as either, lower priced,
medium priced, or higher priced carpets.  This lets you quickly and easily locate carpets that you carry which will
match your customer’s budget.
For lower priced carpet, enter the ceiling price that would constitute a lower priced carpet.  Next enter the lower
limit and the higher limit of what you would consider a medium priced carpet.  Finally, enter the lowest price that
you would consider the bottom end of a higher priced carpet. (See below).

10) Enter the Headers And Footers that will be printed on all material that is printed from this
program. Usually store owners will use their store name as the Header. The header appears at the top of all
printed material.  The  Footer appears at the bottom of all printed material.  This can be the store’s web
address, it’s phone number or whatever you like.

11) Enter Your State’s Sales Tax.
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12) Indicate Whether Or Not Your State Requires You To Charge Sales Tax For Labor.
13) Enter Default Sale Percentage. CompuCarpet can calculate a sale price for any of the carpets stored in
the database.  If you have a sale what is usually the percentage off?  You can change this at any time in the
Setup Defaults window.
14) When You Do Have A Sale Indicate The Carpet Elements Your Sale Applies To. I.E. Carpet, Pad,
And/Or Labor.
15) Enter Customer Message. The software has the ability to write custom e-mail price quotes to your
customers.  You can save a default message in this area and it will appear on all e-mails sent to your
customers.
16) Enter All The Carpet Textures You Carry In Your Store. This will help you quickly and easily
search all carpets that match a specific texture.
17) Enter All The Carpet Yarns You Carry In Your Store. This will help you quickly and easily search
all carpets that match a specific yarn.
18) Click Finish To Save All The Defaults To Your System. When you click Finish the software will go
through all saved records and recalculate all totals based on the values that you have entered.

Once you run the Setup Wizard you can modify any of your default settings by accessing the Defaults
window which can be accessed from the Options menu of the Main program screen.
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One of the most powerful features about this software is the ability it gives the carpet store owner to quickly
and easily change markup rate, pad price, labor rate, sales tax, carpet price range, etc... and have it instantly
update all the other records in your system. If you decide to charge more for labor, simply change the labor
rate in the Defaults window and the change in labor rate will recalculate all the records recorded in your
database. This saves you hours of editing time.

Register Your Software Now:

The first thing you should do after setting up the defaults is to register this software program with Knight-
lite. According to the licensing of this program Knightlite allows you to install this software on up to 2
computers you actually own. You must obtain a registration key from Knightlite. If you do not obtain this
key, the software will stop working after about 12 uses. If you downloaded the demo version and ordered
directly from Knightlite the Registration Code for that computer is included in your software case. If you
did not order directly from Knightlite or would like to install the software on a second computer follow the
instructions below.

1) On the Table of Contents Screen click on HELP.
2) Click on Register This Software.
3) The Registration Window will open.
4) You will see a box labelled This Is Your Key Code.
5) Write that number down and call Knightlite Software Toll Free At: 1-800-707-9875. We will give you
your Registration Key for this computer. Please Note: You must be the registered user of this software
program in order to obtain a Registration Key. The registered user is the user who purchased this soft-
ware directly from Knightlite or one of its qualified resellers.
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To Register the software you will need the following information:

1) The Key Code from your computer program.  This can be found in the Registration Window.

2) The CD Rom Serial Number. This can be found right on the CD itself. It starts with KS.

You can register this software program on-line and receive a key code for your computer via e-mail.
Go to the following URL:
http://knightlite.com/register/

Knightlite allows you to register the software on up to two computers at a time. You don’t have to register
both at the same time.  You can register a second computer at a later time. If you get a new computer or
reformat your hard drive just reregister the new computer. Please see Licensing Agreement for more infor-
mation.

The Main CompuCarpet Window

The Main CompuCarpet window is where you enter all your carpet records and quickly calculate carpet
prices for your customers..  We have designed this window to make data entry as easy as possible.
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To enter records into your carpet database the first thing you should do is to unlock the records. By default
the records are locked.  This is to prevent you from accidently changing or erasing any of your data.  To
unlock the records click on the Options menu item and then on Unlock Records. You can also press Ctrl-
U to unlock them as well.

To navigate between records use the navigational buttons at the lower left hand side of the screen.

To enter a new record click on the NEW button.  The cursor will be positioned in the Style textbox.  Enter
the style of your carpet, and click enter. That will transport you to the Manufacturer textbox, where you
enter the carpet manufacturer’s name.  Click enter again to move to the SCU textbox and enter the SCU.
Click enter and move to the  Yarn combo box. You can use  your mouse or the arrow down/arrow up
keys to move through your list of yarns.  Click enter to select the yarn and move to the Texture combobox.
Again use the arrow down/arrow up keys to select the appropriate texture for your carpet, and again click
enter to move to the Cost textbox. Here you want to enter your cost per square yard for that particular
carpet style. Click enter and the software will automatically calculate the total cost per square yard of your
carpet taking into account all the default values that you had previously entered when you ran the carpet
wizard.  It will also automatically assign the record a price range value that is based also on your default
values.

Press enter until all the fields fill in and the $ appears in the textboxes and then click SAVE to save the
record. To enter a new record, click on NEW and repeat the above process. (Note - Take care when
entering the number in the Cost field.  The program by default enters the decimal point. Take care
not to enter two decimal points or you will get an error.) When a record is saved the database will
automatically sort the database in alphabetical order as to style.

Deleting Records

If you want to delete a record from the database, first click Unlock Records from the  Options menu, then
select the record to be deleted using the navigational buttons, and click DELETE. If you delete the first
record in the database, the database will automatically reset itself. IMPORTANT: Never delete all the
records in any database in this program. In order for the software to function correctly, always have
at least one records stored in the database. Enter at least one of your records before deleting the
sample records.

First
Record

Previous
Record

Next
Record

Last
Record
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Searching the Database For Specific Carpet Records

CompuCarpet 1.0 allows you to search your database of carpets in a variety of ways.  Many of the search
tools can be found under the Search menu.  The software will allow you to search by the following param-
eters:

You can also search for carpet records using Carpet Registers found under the File menu.  You can either
search the carpet register and view records sorted by Style  or sorted by Manufacturer.

When you find the carpet record you would like to view simply double click on the record and it will
display under the main program window.  You can also print out these registers as well by clicking on the
Print button.

You can also search the entire database using key words. Type in any word and the software will return any
record in your database that contains those key words.  You can also use the Keyword button located on the
main program window.
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Sorting Your Carpet Records

You can sort the database of carpet records by Style, Manufacturer, or in Ascending or Descending order.

Searching Carpets Using Texture And Price Range.

Imagine your customer is looking for a plush carpet in a higher price range. Set the left combo box to plush
and the right combo box to high range, and click Search. CompuCarpet will search the database and select
all plush carpets within a higher price range.

Print out any single record from the File menu.
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Calculating Price For A Specific Carpet Size

Once you have found a particular carpet style, you can quickly figure out the cost of the carpet by entering
the carpet size and clicking the Calculate button.  CompuCarpet will calculate the carpet price taking into
account all your default parameters. To choose another style, simply search or scroll to the desired carpet
and click the Calculate button again. The results will refresh to the new carpet style. You can print these
results out.

If your customer would like to order this carpet, or would like a written estimate of the total price, click on
the Create New Customer button and you will be taken to the Customer Information window.
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You can print this information out or start a new customer record by clicking on Create New Customer
Record. The software will load the information onto the Customer Information window.

Calculating Area Carpets

This module  allows you to calculate the price of an area rug.  Select the style and then access this window
by clicking on Calculate Area Rug from the Options menu on the Main program window.

Using this module you can add a binding charge to the total, charge for padding, and labor. You can even
apply discounts just like the Sale module. Clicking on any of the check boxes will automatically recalcu-
late the price of the area rug. Print out the information for the customer, or click Create New Customer
Record to send the information to the Customer Information window.

The Inventory Menu

The Inventory menu allows you to check the current inventory of the displayed carpet style.  If you have a
remnant or roll of that particular style carpet, CompuCarpet will take you to the Inventory Module. You
can view all carpets in your inventory by either clicking  View Current Inventory Window or viewing the
Inventory Register that can
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be either sorted by Style or by Manufacturer. To add the currently displayed carpet style to the inventory
click Add Current Item To Inventory.

The Inventory Module tracks your current inventory of rolls and remnants. You can calculate a price for
your customer that just includes the carpet itself, or any pad or installation charges you would like to add.  It
the carpet is in the form of a roll, you can deduct the length of the carpet from the rest of the roll, so you
always know how much carpet you have in stock for that particular roll.

Print out the information, or send it to the Customer Information window by  clicking on Create New
Customer Record.

View and print out the current inventory from the Inventory Register that you can access from the File
menu.  You can also print out this register as well.
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Backing Up Your Data

You should backup your data files on a regular basis.  There are 2 files that you need to back up.  The first
is called  service.mdb. This file contains all your carpet records, and default settings.  The second file that
you need to backup is the file names.mdb. This file contains all your customer records.  Both files exist in
the C:\Program Files\CompuCarpet. You can access these files using My Computer.

Adding Your Store Logo To The Main Program Window

You can add your own logo to the Main Program window  and replace our CompuCarpet logo.  To do this
create an image using photo imaging software and drag it into the Images folder (see above graphic) To
load your image  click on Change Image from the Options  menu. (Note: Your image must be in the
Images folder in order to load. It will not load from any other path).

You can center your image on the screen using the Adjust Image Position control also accessed from the
Options menu.

Backup These Two Files

Caution: Don’t be fooled by the two files
service.ldb and names.ldb.  These are NOT
your data files.

Place Your Logo Into The Images
Folder
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Program Structure At A Glance

Main

Carpet Registers

Defaults Window

Inventory Sale Area Carpet

Customer Database E-Mail Quote

Customer Register Print Preview



The software comes with an uninstall program that will completely remove it from your system if you no
longer wish to use it.  The software is called  UNWISE, and is located under the C:\Program
Files\CompuCarpet folder.

Technical Support

Telephone Technical Support:

Telephone Support is available for registered users of this program at 203-598-3828 between the hours of
8:00 AM - 8:00 PM Eastern Time Monday -Friday. Weekends by chance.  DO NOT CALL OUR TOLL
FREE ORDER LINE FOR TECHNICAL SUPPORT.  We do not offer support on that line.

You can also e-mail your support questions to us at:

support@compucarpet.com

Make sure you include your name and address plus the CD Rom Serial Number. The Cd Rom Serial
Number is located right on the CD itself and begins with KS.

Knightlite Software
93 Porter Hill

Middlebury, CT 06762
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Uninstalling The Software


